summaryrefslogtreecommitdiffstatsabout
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..7a4903a
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,41 @@
1CLEANFILES = .libs/libmod_gnutls *~
2
3libmod_gnutls_la_SOURCES = mod_gnutls.c
4libmod_gnutls_la_CFLAGS = -Wall ${MODULE_CFLAGS}
5libmod_gnutls_la_LDFLAGS =
6
7lib_LTLIBRARIES = libmod_gnutls.la
8
9make_so: $(lib_LTLIBRARIES)
10 @if test ! -L mod_gnutls.so ; then ln -s .libs/libmod_gnutls.so mod_gnutls.so ; fi
11
12clean:
13 rm -f mod_gnutls.so
14 rm -f *.o *.lo *.la
15 rm -fr .libs
16
17install: make_so
18 @${APXS_BIN} -i -n svn_view mod_gnutls.so
19 @echo ""
20 @echo ""
21 @echo "***********************************************"
22 @echo ""
23 @echo " Please read the documentation at "
24 @echo " http://www.outoforder.cc/ for "
25 @echo " details on configuration of this module "
26 @echo ""
27 @echo "***********************************************"
28 @echo ""
29
30activate: make_so
31 @${APXS_BIN} -i -a -n svn_view mod_gnutls.so
32 @echo ""
33 @echo ""
34 @echo "***********************************************"
35 @echo ""
36 @echo " Please read the documentation at "
37 @echo " http://www.outoforder.cc/ for "
38 @echo " details on configuration of this module "
39 @echo ""
40 @echo "***********************************************"
41 @echo ""