summaryrefslogtreecommitdiffstatsabout
path: root/configure.ac
diff options
context:
space:
mode:
authorEdward Rudd <urkle@outoforder.cc>2004-03-22 20:32:16 (GMT)
committer Edward Rudd <urkle@outoforder.cc>2004-03-22 20:32:16 (GMT)
commit0c653076dbc735757b84b2bc2ff9ee173c246b46 (patch)
treef434360da3eb27d5e3c6fab72473d3d19cf7d0d9 /configure.ac
parent9ac4be0b0c329de114fecf299284e79ea7bab8c9 (diff)
Fixed issue with different include directories for APR and APU.
updated help screen after make install
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9dcc71d..bf8ba6e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
1dnl Required initializer 1dnl Required initializer
2AC_INIT(mod_log_sql, 1.96) 2AC_INIT(mod_log_sql, 1.97)
3AC_PREREQ(2.53) 3AC_PREREQ(2.53)
4AC_CONFIG_HEADERS(config.h) 4AC_CONFIG_HEADERS(config.h)
5 5
@@ -30,6 +30,19 @@ CHECK_PATH_MOD_SSL(
30 30
31AC_SUBST(WANT_SSL_MOD) 31AC_SUBST(WANT_SSL_MOD)
32 32
33case "$target" in
34 *-*-solaris* | *-*-osf* )
35 if test $APACHE_VERSION -eq 1.3; then
36 RTLIBS=-lrt
37 fi
38 ;;
39 *)
40 RTLIBS=""
41 ;;
42esac
43
44AC_SUBST(RTLIBS)
45
33AC_CHECK_HEADERS(limits.h) 46AC_CHECK_HEADERS(limits.h)
34 47
35AC_CONFIG_FILES([stamp-h], [echo timestamp > stamp-h]) 48AC_CONFIG_FILES([stamp-h], [echo timestamp > stamp-h])
@@ -47,5 +60,4 @@ if test $WANT_SSL_MOD -eq 1; then
47else 60else
48 AC_MSG_RESULT([SSL Support : no]) 61 AC_MSG_RESULT([SSL Support : no])
49 AC_MSG_RESULT([*** Use --enable-ssl to enable SSL support]) 62 AC_MSG_RESULT([*** Use --enable-ssl to enable SSL support])
50 AC_MSG_RESULT([*** and --with-ssl-inc for the directory for SSL headers])
51fi 63fi