summaryrefslogtreecommitdiffstatsabout
path: root/configure.ac
diff options
context:
space:
mode:
authorEdward Rudd <urkle@outoforder.cc>2008-09-21 15:54:12 (GMT)
committer Edward Rudd <urkle@outoforder.cc>2008-09-21 15:54:12 (GMT)
commitba30ceeb705e9b4d40ce0d98f6a4e047d47ce919 (patch)
tree5768679317a303031c80be6cba683b6addeb07ac /configure.ac
parentd33662354f64354c601ae257bd5b1b043c484d97 (diff)
moved all modules source to src subdirectory.. Moved header files into include subdirectory
cleaned up makefiles.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 12 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 55de120..07ac486 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,9 +1,9 @@
1dnl Required initializer 1dnl Required initializer
2AC_INIT(mod_log_sql, 1.102) 2AC_INIT([mod_log_sql],[1.102])
3OOO_CONFIG_NICE(config.nice) 3OOO_CONFIG_NICE(config.nice)
4AC_PREREQ(2.53) 4AC_PREREQ(2.59)
5AC_CONFIG_HEADERS(config.h) 5AC_CONFIG_HEADERS(include/config.h)
6AC_CONFIG_SRCDIR(mod_log_sql.c) 6AC_CONFIG_SRCDIR(src/mod_log_sql.c)
7 7
8OOO_MAINTAIN_MODE 8OOO_MAINTAIN_MODE
9 9
@@ -18,7 +18,7 @@ CHECK_APACHE($APACHE13_VERSION,$APACHE20_VERSION,
18 :, 18 :,
19 AC_MSG_ERROR([*** The correct version Apache was not found!]) 19 AC_MSG_ERROR([*** The correct version Apache was not found!])
20 AC_MSG_ERROR([*** You need either Apache 1.3 version $APACHE13_VERSION or greater]) 20 AC_MSG_ERROR([*** You need either Apache 1.3 version $APACHE13_VERSION or greater])
21 AC_MSG_ERROR([*** or Apache 2.0/2.1 version $APACHE20_VERSION or greater!]) 21 AC_MSG_ERROR([*** or Apache 2.0/2.2 version $APACHE20_VERSION or greater!])
22 ) 22 )
23 23
24if test $AP_VERSION = "2.0"; then 24if test $AP_VERSION = "2.0"; then
@@ -29,11 +29,9 @@ fi
29 29
30AC_SUBST(WANT_LOGIO_MOD) 30AC_SUBST(WANT_LOGIO_MOD)
31 31
32if test $AP_VERSION = "2.0"; then 32CHECK_APU_HEADERS([apr_dbd.h],
33 WANT_DBD_MOD=1 33 WANT_DBD_MOD=1,
34else 34 WANT_DBD_MOD=0)
35 WANT_DBD_MOD=0
36fi
37 35
38AC_SUBST(WANT_DBD_MOD) 36AC_SUBST(WANT_DBD_MOD)
39 37
@@ -84,9 +82,11 @@ AC_CONFIG_FILES([stamp-h], [echo timestamp > stamp-h])
84 82
85dnl Write config.status and the Makefile 83dnl Write config.status and the Makefile
86 84
87AC_OUTPUT(Makefile 85AC_CONFIG_FILES([Makefile
86src/Makefile
88docs/Makefile 87docs/Makefile
89contrib/Makefile) 88contrib/Makefile])
89AC_OUTPUT
90 90
91 91
92AC_MSG_RESULT([------------------------------------]) 92AC_MSG_RESULT([------------------------------------])