summaryrefslogtreecommitdiffstatsabout
path: root/configure.ac
diff options
context:
space:
mode:
authorEdward Rudd <urkle@outoforder.cc>2004-01-22 05:26:56 (GMT)
committer Edward Rudd <urkle@outoforder.cc>2004-01-22 05:26:56 (GMT)
commitf230d2468cdc8ee3d290d34a36593b154f51aee1 (patch)
treed823f819136bd34dfa5bb0cba94c6c8c03e852d6 /configure.ac
parentb19a5851171395e196ed686977482d79d7140cfd (diff)
SSL support working under 1.3 and 2.0 as a separate module
preparsing of logformat completed. updated configure scripts to detect mod_ssl.h for 1.3 (mostly)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 808d1fc..7e9ccb8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
1dnl Required initializer 1dnl Required initializer
2AC_INIT(mod_log_sql, 1.93) 2AC_INIT(mod_log_sql, 1.94)
3AC_PREREQ(2.53) 3AC_PREREQ(2.53)
4AC_CONFIG_HEADERS(config.h) 4AC_CONFIG_HEADERS(config.h)
5 5
@@ -24,10 +24,12 @@ CHECK_PATH_MYSQL(:,
24 24
25CHECK_PATH_MOD_SSL( 25CHECK_PATH_MOD_SSL(
26 AC_DEFINE(WANT_SSL_LOGGING,,[Define if we want to compile in SSL support.]) 26 AC_DEFINE(WANT_SSL_LOGGING,,[Define if we want to compile in SSL support.])
27 conf_SSL=1, 27 WANT_SSL_MOD=1,
28 conf_SSL=0 28 WANT_SSL_MOD=0
29 ) 29 )
30 30
31AC_SUBST(WANT_SSL_MOD)
32
31AC_CHECK_HEADERS(limits.h) 33AC_CHECK_HEADERS(limits.h)
32 34
33AC_CONFIG_FILES([stamp-h], [echo timestamp > stamp-h]) 35AC_CONFIG_FILES([stamp-h], [echo timestamp > stamp-h])
@@ -38,7 +40,7 @@ AC_OUTPUT(Makefile Documentation/Makefile)
38 40
39AC_MSG_RESULT([------------------------------------]) 41AC_MSG_RESULT([------------------------------------])
40AC_MSG_RESULT([Apache version : $APACHE_VERSION]) 42AC_MSG_RESULT([Apache version : $APACHE_VERSION])
41if test $conf_SSL -eq 1; then 43if test $WANT_SSL_MOD -eq 1; then
42 AC_MSG_RESULT([SSL Support : yes]) 44 AC_MSG_RESULT([SSL Support : yes])
43else 45else
44 AC_MSG_RESULT([SSL Support : no]) 46 AC_MSG_RESULT([SSL Support : no])