summaryrefslogtreecommitdiffstatsabout
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac54
1 files changed, 35 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index d10ad4f..f2c0df2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,6 +6,8 @@ AC_CONFIG_HEADERS(config.h)
6 6
7AC_CONFIG_SRCDIR(mod_log_sql.c) 7AC_CONFIG_SRCDIR(mod_log_sql.c)
8 8
9OOO_MAINTAIN_MODE
10
9dnl Add a test for a compiler. 11dnl Add a test for a compiler.
10AC_PROG_CC 12AC_PROG_CC
11 13
@@ -19,31 +21,31 @@ CHECK_APACHE($APACHE13_VERSION,$APACHE20_VERSION,
19 AC_MSG_ERROR([*** or Apache 2.0/2.1 version $APACHE20_VERSION or greater!]) 21 AC_MSG_ERROR([*** or Apache 2.0/2.1 version $APACHE20_VERSION or greater!])
20 ) 22 )
21 23
22CHECK_PATH_MYSQL(:, 24CHECK_PATH_MYSQL(
25 WANT_MYSQL_MOD=1,
23 AC_MSG_ERROR([*** Mysql client libraries not found!]) 26 AC_MSG_ERROR([*** Mysql client libraries not found!])
27 WANT_MYSQL_MOD=0
24 ) 28 )
29AC_SUBST(WANT_MYSQL_MOD)
30
31CHECK_PATH_LIBDBI(WANT_DBI_MOD=1,
32 AC_MSG_ERROR([** libDBI client libraries not found!])
33 WANT_DBI_MOD=0
34 )
35AC_SUBST(WANT_DBI_MOD)
36
37dnl to write, checking for pgsql libs
38WANT_PGSQL_MOD=0
39AC_SUBST(WANT_PGSQL_MOD)
40
25 41
26CHECK_PATH_MOD_SSL( 42CHECK_PATH_MOD_SSL(
27 AC_DEFINE(WANT_SSL_LOGGING,,[Define if we want to compile in SSL support.]) 43 AC_DEFINE(WANT_SSL_LOGGING,,[Define if we want to compile in SSL support.])
28 WANT_SSL_MOD=1, 44 WANT_SSL_MOD=1,
29 WANT_SSL_MOD=0 45 WANT_SSL_MOD=0
30 ) 46 )
31
32AC_SUBST(WANT_SSL_MOD) 47AC_SUBST(WANT_SSL_MOD)
33 48
34WANT_MYSQL_MOD=1
35AC_SUBST(WANT_MYSQL_MOD)
36WANT_PGSQL_MOD=0
37AC_SUBST(WANT_PGSQL_MOD)
38WANT_DBI_MOD=1
39DBI_LDFLAGS=""
40DBI_LIBS="-ldbi"
41DBI_CFLAGS=""
42AC_SUBST(DBI_LDFLAGS)
43AC_SUBST(DBI_LIBS)
44AC_SUBST(DBI_CFLAGS)
45AC_SUBST(WANT_DBI_MOD)
46
47case "$target" in 49case "$target" in
48 *-*-solaris* | *-*-osf* ) 50 *-*-solaris* | *-*-osf* )
49 if test $APACHE_VERSION -eq 1.3; then 51 if test $APACHE_VERSION -eq 1.3; then
@@ -70,10 +72,24 @@ contrib/Makefile)
70 72
71 73
72AC_MSG_RESULT([------------------------------------]) 74AC_MSG_RESULT([------------------------------------])
73AC_MSG_RESULT([Apache version : $AP_VERSION]) 75AC_MSG_RESULT([Apache version : $AP_VERSION])
74if test $WANT_SSL_MOD -eq 1; then 76if test $WANT_SSL_MOD -eq 1; then
75 AC_MSG_RESULT([SSL Support : yes]) 77 AC_MSG_RESULT([SSL Support : yes])
76else 78else
77 AC_MSG_RESULT([SSL Support : no]) 79 AC_MSG_RESULT([SSL Support : no])
78 AC_MSG_RESULT([*** Use --enable-ssl to enable SSL support]) 80 AC_MSG_RESULT([*** Use --enable-ssl to enable SSL support])
81fi
82AC_MSG_RESULT([Enabled drivers :])
83if test $WANT_MYSQL_MOD -eq 1; then
84 AC_MSG_RESULT([ MySQL Driver])
79fi 85fi
86if test $WANT_PGSQL_MOD -eq 1; then
87 AC_MSG_RESULT([ PostgreSQL Driver])
88fi
89if test $WANT_DBI_MOD -eq 1; then
90 AC_MSG_RESULT([ libDBI Driver])
91fi
92if test $OOO_MAINTAIN -eq 1; then
93 AC_MSG_RESULT([Maintainer mode is on. -Werror is in effect])
94fi
95AC_MSG_RESULT([------------------------------------])