summaryrefslogtreecommitdiffstatsabout
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 14 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 7cc2653..42e2bde 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,6 @@
1dnl Required initializer 1dnl Required initializer
2AC_INIT(mod_log_sql, 1.97) 2AC_INIT(mod_log_sql, 1.98)
3OOO_CONFIG_NICE(config.nice)
3AC_PREREQ(2.53) 4AC_PREREQ(2.53)
4AC_CONFIG_HEADERS(config.h) 5AC_CONFIG_HEADERS(config.h)
5 6
@@ -10,7 +11,7 @@ AC_PROG_CC
10 11
11APACHE20_VERSION=2.0.40 12APACHE20_VERSION=2.0.40
12APACHE13_VERSION=1.3.20 13APACHE13_VERSION=1.3.20
13CHECK_PATH_APACHE($APACHE13_VERSION,$APACHE20_VERSION, 14CHECK_APACHE($APACHE13_VERSION,$APACHE20_VERSION,
14 :, 15 :,
15 :, 16 :,
16 AC_MSG_ERROR([*** The correct version Apache was not found!]) 17 AC_MSG_ERROR([*** The correct version Apache was not found!])
@@ -30,6 +31,13 @@ CHECK_PATH_MOD_SSL(
30 31
31AC_SUBST(WANT_SSL_MOD) 32AC_SUBST(WANT_SSL_MOD)
32 33
34WANT_MYSQL_MOD=1
35AC_SUBST(WANT_MYSQL_MOD)
36WANT_PGSQL_MOD=0
37AC_SUBST(WANT_PGSQL_MOD)
38WANT_DBI_MOD=0
39AC_SUBST(WANT_DBI_MOD)
40
33case "$target" in 41case "$target" in
34 *-*-solaris* | *-*-osf* ) 42 *-*-solaris* | *-*-osf* )
35 if test $APACHE_VERSION -eq 1.3; then 43 if test $APACHE_VERSION -eq 1.3; then
@@ -43,24 +51,20 @@ esac
43 51
44AC_SUBST(RT_LIBS) 52AC_SUBST(RT_LIBS)
45 53
54
46AC_CHECK_HEADERS(limits.h) 55AC_CHECK_HEADERS(limits.h)
47 56
48AC_CONFIG_FILES([stamp-h], [echo timestamp > stamp-h]) 57AC_CONFIG_FILES([stamp-h], [echo timestamp > stamp-h])
49 58
50PGSQL_LIBS=-lpq
51
52AC_SUBST(PGSQL_LIBS)
53AC_SUBST(PGSQL_LDFLAGS)
54AC_SUBST(PGSQL_CFLAGS)
55
56dnl Write config.status and the Makefile 59dnl Write config.status and the Makefile
57 60
58AC_OUTPUT(Makefile 61AC_OUTPUT(Makefile
59Documentation/Makefile 62docs/Makefile
60contrib/Makefile) 63contrib/Makefile)
61 64
65
62AC_MSG_RESULT([------------------------------------]) 66AC_MSG_RESULT([------------------------------------])
63AC_MSG_RESULT([Apache version : $APACHE_VERSION]) 67AC_MSG_RESULT([Apache version : $AP_VERSION])
64if test $WANT_SSL_MOD -eq 1; then 68if test $WANT_SSL_MOD -eq 1; then
65 AC_MSG_RESULT([SSL Support : yes]) 69 AC_MSG_RESULT([SSL Support : yes])
66else 70else