summaryrefslogtreecommitdiffstatsabout
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 21 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index ed8e25d..63b71db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,11 +8,15 @@ AC_CONFIG_SRCDIR(mod_log_sql.c)
8dnl Add a test for a compiler. 8dnl Add a test for a compiler.
9AC_PROG_CC 9AC_PROG_CC
10 10
11APACHE_VERSION=2.0.44 11APACHE20_VERSION=2.0.44
12CHECK_PATH_APACHE($APACHE_VERSION, 12APACHE13_VERSION=1.3.20
13 :, 13CHECK_PATH_APACHE($APACHE13_VERSION,$APACHE20_VERSION,
14 AC_MSG_ERROR([*** Apache version $APACHE_VERSION not found!]) 14 :,
15 ) 15 :,
16 AC_MSG_ERROR([*** The correct version Apache was not found!])
17 AC_MSG_ERROR([*** You need either Apache 1.3 version $APACHE13_VERSION or greater])
18 AC_MSG_ERROR([*** or Apache 2.0/2.1 version $APACHE20_VERSION or greater!])
19 )
16 20
17CHECK_PATH_MYSQL(:, 21CHECK_PATH_MYSQL(:,
18 AC_MSG_ERROR([*** Mysql client libraries not found!]) 22 AC_MSG_ERROR([*** Mysql client libraries not found!])
@@ -20,10 +24,8 @@ CHECK_PATH_MYSQL(:,
20 24
21CHECK_PATH_MOD_SSL( 25CHECK_PATH_MOD_SSL(
22 AC_DEFINE(WANT_SSL_LOGGING,,[Define if we want to compile in SSL support.]) 26 AC_DEFINE(WANT_SSL_LOGGING,,[Define if we want to compile in SSL support.])
23 AC_MSG_WARN([*** Compilng with SSL support!]), 27 conf_SSL=1,
24 AC_MSG_WARN([*** Compiling without SSL support!]) 28 conf_SSL=0
25 AC_MSG_WARN([*** enable with --enable-ssl to enable])
26 AC_MSG_WARN([*** and --with-ssl-inc with the the directory for SSL headers])
27 ) 29 )
28 30
29AC_CHECK_HEADERS(limits.h) 31AC_CHECK_HEADERS(limits.h)
@@ -33,3 +35,13 @@ AC_CONFIG_FILES([stamp-h], [echo timestamp > stamp-h])
33dnl Write config.status and the Makefile 35dnl Write config.status and the Makefile
34 36
35AC_OUTPUT(Makefile Documentation/Makefile) 37AC_OUTPUT(Makefile Documentation/Makefile)
38
39AC_MSG_RESULT([------------------------------------])
40AC_MSG_RESULT([Apache version : $APACHE_VERSION])
41if test $conf_SSL -eq 1; then
42 AC_MSG_RESULT([SSL Support : yes])
43else
44 AC_MSG_RESULT([SSL Support : no])
45 AC_MSG_RESULT([*** Use --enable-ssl to enable SSL support])
46 AC_MSG_RESULT([*** and --with-ssl-inc for the directory for SSL headers])
47fi