summaryrefslogtreecommitdiffstatsabout
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 24 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index ee2d474..395398f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,15 +1,17 @@
1dnl Required initializer 1dnl Required initializer
2AC_INIT(mod_log_sql, 1.101) 2AC_INIT([mod_log_sql],[1.102])
3OOO_CONFIG_NICE(config.nice) 3OOO_CONFIG_NICE(config.nice)
4AC_PREREQ(2.53) 4AC_PREREQ(2.59)
5AC_CONFIG_HEADERS(config.h) 5AC_CONFIG_HEADERS(include/autoconfig.h)
6 6AC_CONFIG_SRCDIR(src/mod_log_sql.c)
7AC_CONFIG_SRCDIR(mod_log_sql.c)
8 7
9OOO_MAINTAIN_MODE 8OOO_MAINTAIN_MODE
10 9
11dnl Add a test for a compiler. 10dnl Add a test for a compiler.
12AC_PROG_CC 11AC_PROG_CC
12AC_PROG_LIBTOOL
13
14PKG_CHECK_MODULES(PCRE,libpcre)
13 15
14APACHE20_VERSION=2.0.40 16APACHE20_VERSION=2.0.40
15APACHE13_VERSION=1.3.20 17APACHE13_VERSION=1.3.20
@@ -18,7 +20,7 @@ CHECK_APACHE($APACHE13_VERSION,$APACHE20_VERSION,
18 :, 20 :,
19 AC_MSG_ERROR([*** The correct version Apache was not found!]) 21 AC_MSG_ERROR([*** The correct version Apache was not found!])
20 AC_MSG_ERROR([*** You need either Apache 1.3 version $APACHE13_VERSION or greater]) 22 AC_MSG_ERROR([*** You need either Apache 1.3 version $APACHE13_VERSION or greater])
21 AC_MSG_ERROR([*** or Apache 2.0/2.1 version $APACHE20_VERSION or greater!]) 23 AC_MSG_ERROR([*** or Apache 2.0/2.2 version $APACHE20_VERSION or greater!])
22 ) 24 )
23 25
24if test $AP_VERSION = "2.0"; then 26if test $AP_VERSION = "2.0"; then
@@ -26,8 +28,16 @@ if test $AP_VERSION = "2.0"; then
26else 28else
27 WANT_LOGIO_MOD=0 29 WANT_LOGIO_MOD=0
28fi 30fi
31
29AC_SUBST(WANT_LOGIO_MOD) 32AC_SUBST(WANT_LOGIO_MOD)
30 33
34CHECK_APU_HEADERS([apr_dbd.h],
35 WANT_DBD_MOD=1,
36 WANT_DBD_MOD=0)
37
38AC_SUBST(WANT_DBD_MOD)
39CHECK_APU_FUNCS(apr_dbd_transaction_mode_get)
40
31CHECK_MYSQL( 41CHECK_MYSQL(
32 WANT_MYSQL_MOD=1, 42 WANT_MYSQL_MOD=1,
33 AC_MSG_WARN([*** Mysql client libraries not found!]) 43 AC_MSG_WARN([*** Mysql client libraries not found!])
@@ -75,9 +85,12 @@ AC_CONFIG_FILES([stamp-h], [echo timestamp > stamp-h])
75 85
76dnl Write config.status and the Makefile 86dnl Write config.status and the Makefile
77 87
78AC_OUTPUT(Makefile 88AC_CONFIG_FILES([Makefile
89src/Makefile
79docs/Makefile 90docs/Makefile
80contrib/Makefile) 91utility/Makefile
92contrib/Makefile])
93AC_OUTPUT
81 94
82 95
83AC_MSG_RESULT([------------------------------------]) 96AC_MSG_RESULT([------------------------------------])
@@ -105,6 +118,9 @@ fi
105if test $WANT_DBI_MOD -eq 1; then 118if test $WANT_DBI_MOD -eq 1; then
106 AC_MSG_RESULT([ libDBI Driver]) 119 AC_MSG_RESULT([ libDBI Driver])
107fi 120fi
121if test $WANT_DBD_MOD -eq 1; then
122 AC_MSG_RESULT([ APR DBD Driver])
123fi
108if test $OOO_MAINTAIN -eq 1; then 124if test $OOO_MAINTAIN -eq 1; then
109 AC_MSG_RESULT([Maintainer mode is on. -Werror is in effect]) 125 AC_MSG_RESULT([Maintainer mode is on. -Werror is in effect])
110fi 126fi