summaryrefslogtreecommitdiffstatsabout
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 16 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b8a7318..ee2d474 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
1dnl Required initializer 1dnl Required initializer
2AC_INIT(mod_log_sql, 1.100) 2AC_INIT(mod_log_sql, 1.101)
3OOO_CONFIG_NICE(config.nice) 3OOO_CONFIG_NICE(config.nice)
4AC_PREREQ(2.53) 4AC_PREREQ(2.53)
5AC_CONFIG_HEADERS(config.h) 5AC_CONFIG_HEADERS(config.h)
@@ -21,6 +21,13 @@ CHECK_APACHE($APACHE13_VERSION,$APACHE20_VERSION,
21 AC_MSG_ERROR([*** or Apache 2.0/2.1 version $APACHE20_VERSION or greater!]) 21 AC_MSG_ERROR([*** or Apache 2.0/2.1 version $APACHE20_VERSION or greater!])
22 ) 22 )
23 23
24if test $AP_VERSION = "2.0"; then
25 WANT_LOGIO_MOD=1
26else
27 WANT_LOGIO_MOD=0
28fi
29AC_SUBST(WANT_LOGIO_MOD)
30
24CHECK_MYSQL( 31CHECK_MYSQL(
25 WANT_MYSQL_MOD=1, 32 WANT_MYSQL_MOD=1,
26 AC_MSG_WARN([*** Mysql client libraries not found!]) 33 AC_MSG_WARN([*** Mysql client libraries not found!])
@@ -50,7 +57,7 @@ AC_SUBST(WANT_SSL_MOD)
50 57
51case "$target" in 58case "$target" in
52 *-*-solaris* | *-*-osf* ) 59 *-*-solaris* | *-*-osf* )
53 if test $AP_VERSION -eq 1.3; then 60 if test $AP_VERSION = "1.3"; then
54 RT_LIBS=-lrt 61 RT_LIBS=-lrt
55 fi 62 fi
56 ;; 63 ;;
@@ -81,6 +88,13 @@ else
81 AC_MSG_RESULT([SSL Support : no]) 88 AC_MSG_RESULT([SSL Support : no])
82 AC_MSG_RESULT([*** Make sure OpenSSL headers, and mod_ssl.h are installed.]) 89 AC_MSG_RESULT([*** Make sure OpenSSL headers, and mod_ssl.h are installed.])
83fi 90fi
91if test $WANT_LOGIO_MOD -eq 1; then
92 AC_MSG_RESULT([LogIO Module : yes])
93else
94 AC_MSG_RESULT([LogIO Module : no])
95 AC_MSG_RESULT([*** Logio does not work with Apache 1.3.])
96fi
97
84AC_MSG_RESULT([Enabled drivers :]) 98AC_MSG_RESULT([Enabled drivers :])
85if test $WANT_MYSQL_MOD -eq 1; then 99if test $WANT_MYSQL_MOD -eq 1; then
86 AC_MSG_RESULT([ MySQL Driver]) 100 AC_MSG_RESULT([ MySQL Driver])