diff options
author | Edward Rudd | 2004-07-16 01:33:59 +0000 |
---|---|---|
committer | Edward Rudd | 2004-07-16 01:33:59 +0000 |
commit | 197e405e8e8ae8e11bb251305043810c7fa93e4e (patch) | |
tree | c601e247a7073c6385cf739d96de7399c31b5feb /configure.ac | |
parent | 21122f1bb734aa00fc14564d801ea9dc4804c793 (diff) |
fixed another segfault related to the mysql escaping function (forcepreserve bug)
included win32 build bat files in distribution
separated -Werror to a configure time option (--enable-maintainer)
update autogen to use autoconf 2.57, aclocal 1.7
included pgsql and dbi module source in distribution.
setup autodetection in configure script for databases.
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 54 |
1 files changed, 35 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac index d10ad4f..f2c0df2 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -6,6 +6,8 @@ AC_CONFIG_HEADERS(config.h) | |||
6 | 6 | ||
7 | AC_CONFIG_SRCDIR(mod_log_sql.c) | 7 | AC_CONFIG_SRCDIR(mod_log_sql.c) |
8 | 8 | ||
9 | OOO_MAINTAIN_MODE | ||
10 | |||
9 | dnl Add a test for a compiler. | 11 | dnl Add a test for a compiler. |
10 | AC_PROG_CC | 12 | AC_PROG_CC |
11 | 13 | ||
@@ -19,31 +21,31 @@ CHECK_APACHE($APACHE13_VERSION,$APACHE20_VERSION, | |||
19 | AC_MSG_ERROR([*** or Apache 2.0/2.1 version $APACHE20_VERSION or greater!]) | 21 | AC_MSG_ERROR([*** or Apache 2.0/2.1 version $APACHE20_VERSION or greater!]) |
20 | ) | 22 | ) |
21 | 23 | ||
22 | CHECK_PATH_MYSQL(:, | 24 | CHECK_PATH_MYSQL( |
25 | WANT_MYSQL_MOD=1, | ||
23 | AC_MSG_ERROR([*** Mysql client libraries not found!]) | 26 | AC_MSG_ERROR([*** Mysql client libraries not found!]) |
27 | WANT_MYSQL_MOD=0 | ||
24 | ) | 28 | ) |
29 | AC_SUBST(WANT_MYSQL_MOD) | ||
30 | |||
31 | CHECK_PATH_LIBDBI(WANT_DBI_MOD=1, | ||
32 | AC_MSG_ERROR([** libDBI client libraries not found!]) | ||
33 | WANT_DBI_MOD=0 | ||
34 | ) | ||
35 | AC_SUBST(WANT_DBI_MOD) | ||
36 | |||
37 | dnl to write, checking for pgsql libs | ||
38 | WANT_PGSQL_MOD=0 | ||
39 | AC_SUBST(WANT_PGSQL_MOD) | ||
40 | |||
25 | 41 | ||
26 | CHECK_PATH_MOD_SSL( | 42 | CHECK_PATH_MOD_SSL( |
27 | AC_DEFINE(WANT_SSL_LOGGING,,[Define if we want to compile in SSL support.]) | 43 | AC_DEFINE(WANT_SSL_LOGGING,,[Define if we want to compile in SSL support.]) |
28 | WANT_SSL_MOD=1, | 44 | WANT_SSL_MOD=1, |
29 | WANT_SSL_MOD=0 | 45 | WANT_SSL_MOD=0 |
30 | ) | 46 | ) |
31 | |||
32 | AC_SUBST(WANT_SSL_MOD) | 47 | AC_SUBST(WANT_SSL_MOD) |
33 | 48 | ||
34 | WANT_MYSQL_MOD=1 | ||
35 | AC_SUBST(WANT_MYSQL_MOD) | ||
36 | WANT_PGSQL_MOD=0 | ||
37 | AC_SUBST(WANT_PGSQL_MOD) | ||
38 | WANT_DBI_MOD=1 | ||
39 | DBI_LDFLAGS="" | ||
40 | DBI_LIBS="-ldbi" | ||
41 | DBI_CFLAGS="" | ||
42 | AC_SUBST(DBI_LDFLAGS) | ||
43 | AC_SUBST(DBI_LIBS) | ||
44 | AC_SUBST(DBI_CFLAGS) | ||
45 | AC_SUBST(WANT_DBI_MOD) | ||
46 | |||
47 | case "$target" in | 49 | case "$target" in |
48 | *-*-solaris* | *-*-osf* ) | 50 | *-*-solaris* | *-*-osf* ) |
49 | if test $APACHE_VERSION -eq 1.3; then | 51 | if test $APACHE_VERSION -eq 1.3; then |
@@ -70,10 +72,24 @@ contrib/Makefile) | |||
70 | 72 | ||
71 | 73 | ||
72 | AC_MSG_RESULT([------------------------------------]) | 74 | AC_MSG_RESULT([------------------------------------]) |
73 | AC_MSG_RESULT([Apache version : $AP_VERSION]) | 75 | AC_MSG_RESULT([Apache version : $AP_VERSION]) |
74 | if test $WANT_SSL_MOD -eq 1; then | 76 | if test $WANT_SSL_MOD -eq 1; then |
75 | AC_MSG_RESULT([SSL Support : yes]) | 77 | AC_MSG_RESULT([SSL Support : yes]) |
76 | else | 78 | else |
77 | AC_MSG_RESULT([SSL Support : no]) | 79 | AC_MSG_RESULT([SSL Support : no]) |
78 | AC_MSG_RESULT([*** Use --enable-ssl to enable SSL support]) | 80 | AC_MSG_RESULT([*** Use --enable-ssl to enable SSL support]) |
81 | fi | ||
82 | AC_MSG_RESULT([Enabled drivers :]) | ||
83 | if test $WANT_MYSQL_MOD -eq 1; then | ||
84 | AC_MSG_RESULT([ MySQL Driver]) | ||
79 | fi | 85 | fi |
86 | if test $WANT_PGSQL_MOD -eq 1; then | ||
87 | AC_MSG_RESULT([ PostgreSQL Driver]) | ||
88 | fi | ||
89 | if test $WANT_DBI_MOD -eq 1; then | ||
90 | AC_MSG_RESULT([ libDBI Driver]) | ||
91 | fi | ||
92 | if test $OOO_MAINTAIN -eq 1; then | ||
93 | AC_MSG_RESULT([Maintainer mode is on. -Werror is in effect]) | ||
94 | fi | ||
95 | AC_MSG_RESULT([------------------------------------]) | ||